Ngày mới An Nhiên » Công nghệ số » Kinh nghiệm & Thủ thuật » Gia hạn chứng chỉ Let’s Encrypt SSL bị lỗi Certbot cannot be installed

Gia hạn chứng chỉ Let’s Encrypt SSL bị lỗi Certbot cannot be installed

Gần đây nếu bạn thường gia hạn SSL hoặc cài đặt SSL trên VPS, sử dụng các script như: hocvps sẽ gặp lỗi sau:

Skipping bootstrap because certbot-auto is deprecated on this system. Your system is not supported by certbot-auto anymore. Certbot cannot be installed.

Trong thời gian chờ admin các script cập nhật thì bạn có thể chủ động thay thế tập tin /opt/letsencrypt/certbot-auto bằng tập tin:

Sao chép link
https://raw.githubusercontent.com/PolyXGO/letsencrypt-auto-source/9c7d53ffd582b9e4b357c945804a3bbf06d2bb1f/letsencrypt-auto

Cú pháp lệnh:

Sao chép lệnh
sudo wget https://raw.githubusercontent.com/PolyXGO/letsencrypt-auto-source/9c7d53ffd582b9e4b357c945804a3bbf06d2bb1f/letsencrypt-auto -O /opt/letsencrypt/certbot-auto

Sau đó, bạn có thể cài đặt và gia hạn chứng chỉ SSL cho web/ blog bình thường qua lệnh:

/opt/letsencrypt/certbot-auto renew –pre-hook “service nginx stop” –post-hook “service nginx start”

[Solution] Your system is not supported by certbot-auto anymore

Leave a Comment

Email của bạn sẽ không được hiển thị công khai.

Website này sử dụng Akismet để hạn chế spam. Tìm hiểu bình luận của bạn được duyệt như thế nào.